ब्लॉगर में jQuery के दो भिन्न संस्करण प्रयोग करना

80

यदि आप अपने ब्लॉग पर दो ऐसे विजेट इस्तेमाल करते हैं जिसमें jQuery के दो भिन्न संस्करण प्रयोग में लाये जा रहे हों तो यह पाया कि न चाहकर भी बहुत बार दोनों में कंफ्लिक्ट हो ही जाता है। कभी-कभी ऐसा भी पाया गया है कि यदि हम jQuery का नया संस्करण प्रयोग करें तो विजेट काम करना बंद कर देता है। ऐसा होने पर हमें jQuery के दोनों संस्करण अपने ब्लॉग पर रखने होते हैं। दोनों वर्शन बिना किसी समस्या को उत्पन्न किये अपना काम करते रहें इसके निम्न उपाय करना ज़रूरी है।

जिसके लिए आपको पहली वाली jQuery के ठीक नीचे कंफ्लिक्ट न करने का निर्देश बताना होता है। उदाहरण नीचे दिया जा रहा है।

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js'></script>

<script type='text/javascript'>
var $jq = jQuery.noConflict();
</script>

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.2/jquery.min.js'></script>

उपरोक्त कोड में पंक्ति 3 से 5 तक वो निर्देश है जिसे आपको अपने टेम्पलेट में सबसे पहली jQuery के नीचे पेस्ट करना पड़ेगा।

आशा करता हूँ यह छोटा सा मगर उपयोगी कोड अपनी सहायता आज नहीं तो कल कर ही सकता है।